Crash when undoing after deploying

Post your technical problems here.
cm[]
Cadet
Posts: 4
Joined: Sat May 26, 2012 8:44 am

Crash when undoing after deploying

Unread postby cm[] » Sat May 26, 2012 10:09 am

Hello,

just found a nasty crashing bug. If you deploy a unit from the reserve and then press undo, the game does CTD.

The platform I'm using is OSX 10.6, and I get the following error:

26.05.12 12:04:12 uoc[73249] Unity of Command Error
26.05.12 12:05:34 com.apple.launchd.peruser.501[205] ([0x0-0x59c59c].net.unityofcommand.uoc[73249]) Exited with exit code: 255

Steps to reproduce:

1. Start new Axis campaign
2. In first mission, deploy 22nd Panzer to one of the hexes directly besides the river
3. Press undo
-> Application freezes, then crash to Desktop :shock:

User avatar
Tomislav Uzelac
2x2 Games
Posts: 1336
Joined: Mon Apr 04, 2011 11:24 pm
Location: Zagreb, Croatia

Re: Crash when undoing after deploying

Unread postby Tomislav Uzelac » Sat May 26, 2012 11:07 am

Another one today.. oh boy :?

We're on it, thanks for reporting!

RambOrc
Captain
Posts: 46
Joined: Fri Apr 27, 2012 3:20 pm

Re: Crash when undoing after deploying

Unread postby RambOrc » Sat May 26, 2012 11:48 am

Never seen any of the bugs here and in the prestige thread running OS X 10.7 and UoC 1.00 so probably new in 1.02.

User avatar
Tomislav Uzelac
2x2 Games
Posts: 1336
Joined: Mon Apr 04, 2011 11:24 pm
Location: Zagreb, Croatia

Re: Crash when undoing after deploying

Unread postby Tomislav Uzelac » Sat May 26, 2012 5:35 pm

We fixed this, and we'll be issuing a preliminary patch in a little while. Thanks for reporting.

@RambOrc: yes, undo is the problem here. It tries to reselect the unit that was the subject of the undo action, but of course prior to undo no such unit exists, because the player just freakin bought it!!! :oops: :cry: