[Linux] fullscreen mode not working with KDE

Post your technical problems here.
dartom
Cadet
Posts: 3
Joined: Sat Feb 16, 2013 12:37 pm

[Linux] fullscreen mode not working with KDE

Unread postby dartom » Sat Feb 16, 2013 1:13 pm

OpenSuSE 12.2 64-bit, KDE 4.8.5

The game opens a screen-sized window, but it is not actually flagged as fullscreen. This causes the bottom panel to be displayed above the window, hiding the bottom controls - including, for example, the 'Start campaign' button.

As a workaround, KDE's window manager is able to force window settings - with these, I was able to override the game window settings to force it into fullscreen mode like this:
- start the game and alt-tab away
- open KDE control center, select Window behavior / Window rules
- click New, click the detect button, click on the game's window and press OK.
- Go to the Size and position tab, enable the Fullscreen one and choose Force in the combo box
- OK/apply
- exit game and restart. Should now be properly fullscreen

User avatar
Tomislav Uzelac
2x2 Games
Posts: 1336
Joined: Mon Apr 04, 2011 11:24 pm
Location: Zagreb, Croatia

Re: [Linux] fullscreen mode not working with KDE

Unread postby Tomislav Uzelac » Sun Feb 17, 2013 5:28 pm

You can add "sdl-fullscreen" to launch options, but then you lose the ability to ALT-TAB which is why I am not setting that method as the default.

If your method works, and you can still ALT-TAB, you're probably better off.

dartom
Cadet
Posts: 3
Joined: Sat Feb 16, 2013 12:37 pm

Re: [Linux] fullscreen mode not working with KDE

Unread postby dartom » Sun Feb 17, 2013 6:30 pm

Ah, makes sense. Thanks!


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest