Huge delay when I start the game

Post your technical problems here.
RedArmy
Cadet
Posts: 4
Joined: Wed Oct 24, 2012 7:29 pm

Huge delay when I start the game

Unread postby RedArmy » Wed Oct 24, 2012 7:33 pm

It can take almost 1 minute when I start the game by clicking on its icon until I see the game's menu. When I close the game and start it a second time, the delay is completely gone and the game starts in less than a second. After a certain time, the problem returns again. Quite annoying.
After some testing I noticed that it's related to the folder fontconfig in temp. I like to clean my temp folder on a regular basis, since it's breeding ground of all kind of software issues, spam and viruses. Deleting fontconfig shouldn't have such a huge impact on this game. In my opinion the temp folder should only be used for temporary files. Files that should not be deleted by a user emptying the folder, should stay open so that they are impossible to delete. Emptying a temp folder should have no negative impact.

Gryphonrider
Captain
Posts: 28
Joined: Wed Nov 16, 2011 8:32 pm
Location: Utrecht, The Netherlands
Contact:

Re: Huge delay when I start the game

Unread postby Gryphonrider » Wed Oct 24, 2012 8:44 pm

Thank you for posting your findings!
I wondered myself what was causing this delay, and how to solve it.
Will test your workaround asap and report back.

RedArmy
Cadet
Posts: 4
Joined: Wed Oct 24, 2012 7:29 pm

Re: Huge delay when I start the game

Unread postby RedArmy » Wed Oct 24, 2012 8:52 pm

Type %temp% in explorer to open the temp folder and delete the fontconfig folder,start the game and you should see the delay.

Gryphonrider
Captain
Posts: 28
Joined: Wed Nov 16, 2011 8:32 pm
Location: Utrecht, The Netherlands
Contact:

Re: Huge delay when I start the game

Unread postby Gryphonrider » Wed Oct 24, 2012 9:11 pm

The map fontconfig indeed seems to affect loading time.
Something for the developers to look into.
It's not a major issue though (imho).

User avatar
Tomislav Uzelac
2x2 Games
Posts: 1336
Joined: Mon Apr 04, 2011 11:24 pm
Location: Zagreb, Croatia

Re: Huge delay when I start the game

Unread postby Tomislav Uzelac » Thu Oct 25, 2012 9:49 am

Interesting! It's an external dependency, so I'm not sure we can do a whole lot about fontconfig. It's required if you want to work with freetype, which we really really do :?

However, this thing could in fact be the source of some other problems. Really grateful for tracking this down RedArmy ;)

wobbly
Second Lieutenant
Posts: 9
Joined: Tue Oct 23, 2012 3:20 pm

Re: Huge delay when I start the game

Unread postby wobbly » Thu Oct 25, 2012 9:22 pm

RedArmy wrote:It can take almost 1 minute when I start the game by clicking on its icon until I see the game's menu. When I close the game and start it a second time, the delay is completely gone and the game starts in less than a second. After a certain time, the problem returns again. Quite annoying.
After some testing I noticed that it's related to the folder fontconfig in temp. I like to clean my temp folder on a regular basis, since it's breeding ground of all kind of software issues, spam and viruses. Deleting fontconfig shouldn't have such a huge impact on this game. In my opinion the temp folder should only be used for temporary files. Files that should not be deleted by a user emptying the folder, should stay open so that they are impossible to delete. Emptying a temp folder should have no negative impact.
Last edited by wobbly on Fri Oct 26, 2012 3:31 pm, edited 1 time in total.

RedArmy
Cadet
Posts: 4
Joined: Wed Oct 24, 2012 7:29 pm

Re: Huge delay when I start the game

Unread postby RedArmy » Thu Oct 25, 2012 9:32 pm

wobbly wrote:try my screen refresh fix because as well as the ghosting problem I had a bit of lag on load screen and in game,it was going to be the next thing I fixed but my first fix sorted it out good and proper,good luck


Thanks wobbly, but why should I try to use your fix for an issue I don't have? It seems to me that you're using a band-aid solution that basically camouflages an underlying issue with your current system.

Tomislav Uzelac wrote:It's an external dependency, so I'm not sure we can do a whole lot about fontconfig.

A program called ServeToMe uses a dedicated folder like \AppData\Roaming\.servetome-fontconfig\ to avoid any issues. Contact its author at http://projectswithlove.com/ and he might give you a quick solution that can save you lots of time.

wobbly
Second Lieutenant
Posts: 9
Joined: Tue Oct 23, 2012 3:20 pm

Re: Huge delay when I start the game

Unread postby wobbly » Fri Oct 26, 2012 4:06 pm

RedArmy wrote:It can take almost 1 minute when I start the game by clicking on its icon until I see the game's menu. When I close the game and start it a second time, the delay is completely gone and the game starts in less than a second. After a certain time, the problem returns again. Quite annoying.
After some testing I noticed that it's related to the folder fontconfig in temp. I like to clean my temp folder on a regular basis, since it's breeding ground of all kind of software issues, spam and viruses. Deleting fontconfig shouldn't have such a huge impact on this game. In my opinion the temp folder should only be used for temporary files. Files that should not be deleted by a user emptying the folder, should stay open so that they are impossible to delete. Emptying a temp folder should have no negative impact.


================================================================================================================================
It can take almost 1 minute when I start the game When I close the game and start it a second time, the delay is completely gone and the game starts in less than a second
================================================================================================================================
This is one of the problems I had,granted not every time I played but it was still often enough to annoy ,but still what do I know? me and band aid-solutions ha!.Maybe my PC has got some underlying issues but my game is working, so when you have some spare time away from your perfect rig you would do well to start working on your manners,after all it was only a suggestion,good luck with finding a soulution :x

RedArmy
Cadet
Posts: 4
Joined: Wed Oct 24, 2012 7:29 pm

Re: Huge delay when I start the game

Unread postby RedArmy » Wed Oct 31, 2012 6:50 am

wobbly wrote:you would do well to start working on your manners,after all it was only a suggestion


1. May I remind you that my very first words were "Thanks Wobbly". But God forbid if I ask you why I should use a solution for a problem that I don't have. Since when is it bad manners to ask a question?

2. I work in the IT for for almost 24 years so I have to right to write "It seems to me that you're using a band-aid solution". May I also remind you that I wrote "It seems", which indicates that I'm only making an assumption, which is not the same as claiming that it's a fact. Since when is it bad manners to make an innocent assumption based on 24 years of professional experience?

3. I have never claimed that I have a perfect system, you just use that make me look bad.

4. You should never abuse a public forum to talk bad about people. If you have a personal issue with me or anyone else, then you either contact a moderator or you message this person.


Since you preferred to public, you left me not other choice than to react in public and also to say this: it's you who needs to work on manners.

I have nothing more to add.