Huge delay when I start the game

Post your technical problems here.
RedArmy
Cadet
Posts: 4
Joined: Wed Oct 24, 2012 7:29 pm

Huge delay when I start the game

Unread postby RedArmy » Wed Oct 24, 2012 7:33 pm

It can take almost 1 minute when I start the game by clicking on its icon until I see the game's menu. When I close the game and start it a second time, the delay is completely gone and the game starts in less than a second. After a certain time, the problem returns again. Quite annoying.
After some testing I noticed that it's related to the folder fontconfig in temp. I like to clean my temp folder on a regular basis, since it's breeding ground of all kind of software issues, spam and viruses. Deleting fontconfig shouldn't have such a huge impact on this game. In my opinion the temp folder should only be used for temporary files. Files that should not be deleted by a user emptying the folder, should stay open so that they are impossible to delete. Emptying a temp folder should have no negative impact.

Gryphonrider
Captain
Posts: 33
Joined: Wed Nov 16, 2011 8:32 pm
Location: Utrecht, The Netherlands
Contact:

Re: Huge delay when I start the game

Unread postby Gryphonrider » Wed Oct 24, 2012 8:44 pm

Thank you for posting your findings!
I wondered myself what was causing this delay, and how to solve it.
Will test your workaround asap and report back.

RedArmy
Cadet
Posts: 4
Joined: Wed Oct 24, 2012 7:29 pm

Re: Huge delay when I start the game

Unread postby RedArmy » Wed Oct 24, 2012 8:52 pm

Type %temp% in explorer to open the temp folder and delete the fontconfig folder,start the game and you should see the delay.

Gryphonrider
Captain
Posts: 33
Joined: Wed Nov 16, 2011 8:32 pm
Location: Utrecht, The Netherlands
Contact:

Re: Huge delay when I start the game

Unread postby Gryphonrider » Wed Oct 24, 2012 9:11 pm

The map fontconfig indeed seems to affect loading time.
Something for the developers to look into.
It's not a major issue though (imho).

User avatar
Tomislav Uzelac
2x2 Games
Posts: 1878
Joined: Mon Apr 04, 2011 11:24 pm
Location: Zagreb, Croatia

Re: Huge delay when I start the game

Unread postby Tomislav Uzelac » Thu Oct 25, 2012 9:49 am

Interesting! It's an external dependency, so I'm not sure we can do a whole lot about fontconfig. It's required if you want to work with freetype, which we really really do :?

However, this thing could in fact be the source of some other problems. Really grateful for tracking this down RedArmy ;)

wobbly
Second Lieutenant
Posts: 9
Joined: Tue Oct 23, 2012 3:20 pm

Re: Huge delay when I start the game

Unread postby wobbly » Thu Oct 25, 2012 9:22 pm

Last edited by wobbly on Fri Oct 26, 2012 3:31 pm, edited 1 time in total.

RedArmy
Cadet
Posts: 4
Joined: Wed Oct 24, 2012 7:29 pm

Re: Huge delay when I start the game

Unread postby RedArmy » Thu Oct 25, 2012 9:32 pm


wobbly
Second Lieutenant
Posts: 9
Joined: Tue Oct 23, 2012 3:20 pm

Re: Huge delay when I start the game

Unread postby wobbly » Fri Oct 26, 2012 4:06 pm


RedArmy
Cadet
Posts: 4
Joined: Wed Oct 24, 2012 7:29 pm

Re: Huge delay when I start the game

Unread postby RedArmy » Wed Oct 31, 2012 6:50 am