UoC hangs when I quit (Mac OS X 10.10.5)

Post your technical problems here.
nebularscan
Newcomer
Posts: 1
Joined: Wed Jul 06, 2016 1:57 am

UoC hangs when I quit (Mac OS X 10.10.5)

Unread postby nebularscan » Wed Jul 06, 2016 2:07 am

Hi,

Just bought UoC and been playing it through Steam for a couple of days. Would appreciate any help fixing this. Here are my problems:

1. Every time I quit the game, it hangs. The UoC full-screen disappears and the system displays the Steam screen, but when I try to quit Steam, it refuses because it says UoC is still running. I have to use Activity Monitor to kill the process.

2. Every time I start a game, I get prompted to copy the key so that I could enter it for activation. However, I am never prompted when I start playing. So every time I open UoC, it asks me to copy the key so I could enter it.

3. I researched the forums but did not find any specific advice about this problem. But I tried running UoC on Safe Mode -- it opened in a windowed environment. I started a campaign, then quit and this time, it quit just fine.

Some additional info:
I first downloaded and played the demo version via Steam. Then I bought it and installed again via Steam.

Mac Specs:
Mac OS X 10.10.5
2 GHz Intel Core i7
8 GB 1600 MHz DDR3
Intel HD Graphics 4000 1024 MB

User avatar
aesqe
Marching band
Posts: 87
Joined: Wed Mar 16, 2011 9:04 pm
Contact:

Re: UoC hangs when I quit (Mac OS X 10.10.5)

Unread postby aesqe » Wed Jul 06, 2016 10:22 pm

Hi nebularscan!

1. Unfortunately, I really don't have any idea why the game hangs on exit on your computer, sorry :/
Is your display resolution perhaps set to "scaled" or something similar?

2. This most likely has to do with permissions on your "~/Library/Application Support/Unity of Command" folder - can you check if you have read/write access to it?

3. If the game exits properly when in windowed mode, then maybe the best option is to leave it in windowed mode, but adjust the resolution to match your screen.
I know it's not a perfect solution, but I can't think of anything better at the moment.
- click on "Options" from the main menu
- set "Screen Size" to "Window" and enter your screen resolution
- click "Main Menu" button at the bottom to apply changes
- click "Continue" button in the popup
- restart the game (in normal, not "safe" mode)

Let me know how it goes!


Return to “Technical Support”

Who is online

Users browsing this forum: Google [Bot] and 2 guests