Won't Start On Linux

Post your technical problems here.
nikdav
Lieutenant Colonel
Posts: 129
Joined: Sun Feb 19, 2012 1:05 pm
Location: Italy

Re: Won't Start On Linux

Unread postby nikdav » Fri Nov 28, 2014 5:23 pm

A good game don't have life cycle, i had some new modern games with a " life cycle " of only days on my pc,
on the other side i have today games as SSI Fighting Steel, the first Total war series, the SSG series,
the first Close Combat series, etc.... that are milestone as UOC and with some patience can work on modern pc forever ! ;)

User avatar
Tomislav Uzelac
2x2 Games
Posts: 1321
Joined: Mon Apr 04, 2011 11:24 pm
Location: Zagreb, Croatia

Re: Won't Start On Linux

Unread postby Tomislav Uzelac » Mon Dec 01, 2014 11:31 am

nikdav wrote: UOC [...]with some patience can work on modern pc forever


True, but I will still make sure it's updated (Linux, OpenGL, etc.) before we completely abandon the project.

This isn't a priority as long as there's a workaround though. For example, Linux fixes will likely require re-doing the installer (lots of work) and I prefer to do that when I work on the installer for the new game. Saves time, like that.

BTRE
Newcomer
Posts: 1
Joined: Sat Mar 21, 2015 4:31 am

Re: Won't Start On Linux

Unread postby BTRE » Sat Mar 21, 2015 4:39 am

Hi I recently reinstalled the game on a whim and it won't launch. It used to work but now I get the following error in the terminal when I try to launch:

ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib/i386-linux-gnu/alsa-lib/libasound_module_rate_speexrate_best.so
ALSA lib pcm_rate.c:1399:(snd_pcm_rate_open) Cannot find rate converter
Fatal Python error: (pygame parachute) Segmentation Fault
Aborted (core dumped)

This is the Steam version and I haven't tried the non-steam version again (got both versions because I like the game a lot) and I'm running Arch x64. Turning off the steam overlay doesn't seem to help. Do I have to create a symlink for the missing library or is the segfault something else entirely? The log in .uoc is empty.


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest